Draper v2.0.0 Release Notes

Release Date: 2015-03-27 // over 6 years ago
  • Working to breathe new life into the project by shedding baggage.

    • ๐Ÿš… Rails 3.2 support dropped
    • ๐Ÿ’Ž Ruby 1.9.3 and 2.0 support dropped
    • โž• Add support for Rails 4.2 and Ruby 2.2
    • โœ… Rewrite tests to get over RSpec deprecations
    • Get RSpec up to 3.2
    • Try to un-screw the challenges of ActiveModelSerializers

    ๐Ÿ‘ Due to the breakages of dropping legacy support, we've bumped the major version. From here, ๐Ÿšš development effort will likely focus on a version 3.0 that removes features and simplifies usage of the library.