Fluentd v1.14.2 Release Notes

Release Date: 2021-10-29 // 8 months ago
  • ๐Ÿš€ IMPORTANT: This release contain the fix for CVE-2021-41186 - ๐Ÿ“œ ReDoS vulnerability in parser_apache2. This vulnerability is affected from Fluentd v0.14.14 to v1.14.1. โฌ†๏ธ We recommend to upgrade Fluentd to v1.14.2 or use patched version of ๐Ÿ”Œ parser_apache2 plugin.

    โœจ Enhancement

    ๐Ÿ› Bug fix

    • ๐Ÿ›  Fixed to generate correct epoch timestamp even after switching Daylight Saving Time https://github.com/fluent/fluentd/pull/3524
    • ๐Ÿ›  Fixed ReDoS vulnerability in parser_apache2. This vulnerability is caused by a certain pattern of a broken apache log.