PaperClip v5.0.0.beta1 Release Notes

Release Date: 2016-04-20 // over 5 years ago

    ⬇️ Drop support to end-of-life'd ruby 2.0.

    ⬇️ Drop support for end-of-life'd Rails 3.2 and 4.1

    ⬇️ Drop support for AWS v1

    ✂ Remove tests for JRuby and Rubinius from Travis CI (they were failing)

    👌 Improvement: Add fog_options configuration to send options to fog when
    storing files.

    Extracted repository for locales only: https://github.com/thoughtbot/paperclip-i18n

    🖨 Bugfix: Original file could be unlinked during post_process_style, producing failures

    🛠 Bugfix for image magick scaling images up

    Memory consumption improvements

    0️⃣ url on a unpersisted record returns default_url rather than nil

    👌 Improvement: aws-sdk v2 support
    #1903

    If your Gemfile contains aws-sdk (>= 2.0.0) and aws-sdk-v1, paperclip will use
    aws-sdk v2. With aws-sdk v2, S3 storage requires you to set the s3_region.
    s3_region may be nested in s3_credentials, and (if not nested in
    s3_credentials) it may be a Proc.