All Versions
10
Latest Version
Avg Release Cycle
198 days
Latest Release
1246 days ago

Changelog History

  • v0.4.1

    March 09, 2017
    • 👌 Support Rails 4.2.8 (@spastorino)
    • ⏪ Restore Ruby 1.8.7 support (@spastorino)
    • ➕ Add tests against all the supported Rubies and Rails versions (@spastorino)
  • v0.4.0

    January 22, 2015
    • 💎 Rubinius rubysl ~> 2.1 and added gem psysch into :rbx section of Gemfiles (@bearded)
    • 💎 Require Ruby 2.2 for Rails 5.0 (@bearded)
    • ✂ Removed ActionController::HideActions (@bearded)
    • 💎 bcrypt-ruby was renamed to bcrypt (@djbender)
    • Fixing use of deprecated serve_static_assets config option (@theunraveler)
    • ActionDispatch::Head replaced by Rack::Head (@bearded)
    • 🚅 Converted Rails4 checks into Rails3 checks (@bearded)
    • ✅ Green tests on Rails 5.0.0.alpha (@bearded)
  • v0.3.1

    October 23, 2014
  • v0.3.0

    October 14, 2014
    • 👉 Use strong params on scaffolding (@txdavidtx)
    • Add support for Rails 4.1 protected_instance_variables (@edowling)
    • 🛠 Fix rails-api new with --skip-active-record (@spastorino)
  • v0.2.1

    May 09, 2014
    • 🛠 Fix Rails 4.1 Gemfile generation issues (@neoeno, @RMaksymczuk, @spastorino)
  • v0.2.0

    January 13, 2014
    • 🚅 Rails 4.1 support (@jpteti, @litch, @bmorton)
    • ➕ Add session management to Rails 4 stack if config.session_store is supplied and config.api_only = false (@tamird)
  • v0.1.0

    April 01, 2013
    • ✂ Remove Ruby 1.9.2 support. (@steveklabnik)
    • 🔒 Ensure we require dependencies without security issues (@carlosantonio)
    • 🛠 Fix BestStandardsSupport, no longer in Rails 4 (@et)
    • ✂ Remove old info about Rails from README (@garysweaver)
    • 🍱 Don't generate assets by default (@kjg)
  • v0.0.3

    December 18, 2012
    • ➕ Add config.api_only, set it to false in case you want to use Rails default middleware stack. (@spastorino)
    • Return proper format on exceptions. (@spastorino)
    • Generate a specific wrap_parameters initializer, with commented out logic, since it's not enabled by default as the Rails template says.
    • ✂ Remove wrap_parameters compatibility method, to allow enabling it if required.
    • 🚅 Require Rails >= 3.2.6.
  • v0.0.2

    June 06, 2012
    • 🚅 Use correct SSL middleware for Rails 3.2.x compatibility. (@philm)
    • ➕ Add helper to compatibility methods for Rails 3.2.x. (@wintery)
    • ➕ Add helper_method to compatibility methods for Rails 3.2.x. (@educobuci)
    • Do not generate tmp and vendor directories. (@dpowell)
    • ✂ Remove jquery-rails from generated Gemfile. (@dpowell)
  • v0.0.1

    April 20, 2012
    • 🚀 First release.