shoulda-matchers v5.0.0 Release Notes

Release Date: 2021-07-09 // 4 months ago
  • ๐Ÿ› Bug fixes

    • ๐Ÿš… Replace in?, method from ActiveSupport, with include? to prevent exception "undefined method in?" on non-Rails app. (#1405)

    ๐Ÿ”‹ Features

    • โž• Add support for Rails 6.1. No new Rails 6.1 features are supported, but only existing features that broke with the upgrade. (#1418)

    • โž• Add support for RVM (Ruby Version Manager) to setting up local environment. (#1424)

    • โž• Add support for alias in matcher define_enum. (#1419)

    • โž• Add support for Ruby 3.0. (#1406, #1427)

    ๐Ÿ‘Œ Improvements

    • โœ‚ Remove deprecated warnings emitted on Rails 6.1 in ActiveModel errors. (#1444)

    Backward-incompatible changes

    • โฌ‡๏ธ Drop support for Rails 4.2, 5.0 and 5.1 as well as Ruby 2.4 and 2.5 they've been end-of-lifed. The gem now supports Ruby 2.6+ and Rails 5.2+. (#1412, #1415, #1422, #1428, #1429)

    • Remove deprecated matchers: use_before_filter, use_after_filter, use_around_filter and allow_mass_assignment_of. (#1430, #1431)


Previous changes from v5.0.0.rc1

  • ๐Ÿ› Bug fixes

    • ๐Ÿš… Replace in?, method from ActiveSupport, with include? to prevent exception "undefined method in?" on non-Rails app. (#1405)

    ๐Ÿ”‹ Features

    • โž• Add support for Rails 6.1. No new Rails 6.1 features are supported, but only existing features that broke with the upgrade. (#1418)

    • โž• Add support for RVM (Ruby Version Manager) to setting up local environment. (#1424)

    • โž• Add support for alias in matcher define_enum. (#1419)

    • โž• Add support for Ruby 3.0. (#1406, #1427)

    Backward-incompatible changes

    • โฌ‡๏ธ Drop support for Rails 4.2, 5.0 and 5.1 as well as Ruby 2.4 and 2.5 they've been end-of-lifed. The gem now supports Ruby 2.6+ and Rails 5.2+. (#1412, #1415, #1422, #1428, #1429)

    • Remove deprecated matchers: use_before_filter, use_after_filter, use_around_filter and allow_mass_assignment_of. (#1430, #1431)