All Versions
20
Latest Version
Avg Release Cycle
135 days
Latest Release
1091 days ago

Changelog History
Page 1

  • v0.10.0 Changes

    September 30, 2019

    โž• Added

    • โž• Add tty-logger component

    ๐Ÿ”„ Changed

    • โšก๏ธ Change to update all dependencies
  • v0.9.1 Changes

    December 27, 2018

    ๐Ÿ›  Fixed

    • ๐Ÿ›  Fix gemspec files loading to include all necessary files and fix teletype
  • v0.9.0 Changes

    December 25, 2018

    โž• Added

    • โž• Add tty-box component
    • โž• Add tty-pie component

    ๐Ÿ”„ Changed

    • ๐Ÿ”„ Change to require Ruby >= 2.0
    • ๐Ÿ”„ Change to freeze strings
    • ๐Ÿ”„ Change to relax tty-color, tty-cursor, tty-screen, tty-which constraints
  • v0.8.1 Changes

    June 25, 2018

    ๐Ÿ”„ Changed

    • โšก๏ธ Update tty-markdown dependency
    • โšก๏ธ Update tty-progressbar dependency
  • v0.8.0 Changes

    May 31, 2018

    โž• Added

    • โž• Add teletype executable for jump starting new CLI apps
    • โž• Add TTY::CLI for scaffolding new console applications
    • โž• Add Commands::New for generating new command line applications
    • โž• Add Commands::Add for adding new commands & subcommands
    • โž• Add Plugins#load_from to allow loading dependencies from gemspec
    • โž• Add tty-tree component
    • โž• Add tty-markdown component
    • โž• Add tty-font component
    • โž• Add tty-config component

    ๐Ÿ”„ Changed

    • โœ‚ Remove Plugins#find
    • ๐Ÿ”„ Change Plugins#load to Plugins#activate
    • โœ‚ Remove metrics rake tasks
    • โšก๏ธ Update dependencies
  • v0.7.0 Changes

    March 26, 2017

    ๐Ÿ”„ Changed

    • โšก๏ธ Update tty-prompt dependency
    • โšก๏ธ Update tty-cursor dependency
    • โšก๏ธ Update tty-pager dependency
    • โšก๏ธ Update tty-which dependency
    • โšก๏ธ Update tty-file dependency
    • โšก๏ธ Update tty-editor dependency
  • v0.6.1 Changes

    February 26, 2017

    ๐Ÿ”„ Changed

    • โšก๏ธ Update tty-command dependency
  • v0.6.0 Changes

    January 28, 2017

    โž• Added

    • โž• Add tty-editor dependency
    • โž• Add tty-file dependency

    ๐Ÿ”„ Changed

    • ๐Ÿ”„ Change to use plugin system to load all tty dependencies
    • โœ‚ Remove coercion, delegatable & unicode support
    • โœ‚ Remove error types from TTY module namespace
    • โœ‚ Remove System::Editor
    • โœ‚ Remove Vector
    • โœ‚ Remove Logger
    • โœ‚ Remove Terminal & Terminal:Home
  • v0.5.0 Changes

    May 30, 2016

    โž• Added

    • โž• Add tty-command dependency

    ๐Ÿ”„ Changed

    • โšก๏ธ Update tty-progressbar dependency
    • โšก๏ธ Update tty-prompt dependency
    • โšก๏ธ Update tty-spinner dependency
  • v0.4.0 Changes

    February 13, 2016

    โž• Added

    • โž• Add tty-color dependency

    ๐Ÿ”„ Changed

    • โšก๏ธ Update dependencies