All Versions
112
Latest Version
Avg Release Cycle
5 days
Latest Release
187 days ago
Changelog History
Page 8
Changelog History
Page 8
-
v1.2.5 Changes
- #354 - Expose consumer heartbeat
- #373 - Async producer not working properly with responders
-
v1.2.4 Changes
- #332 - Fetcher for max queue size
-
v1.2.3 Changes
- ๐ #313 - support PLAINTEXT and SSL for scheme
- ๐ #288 - drop activesupport callbacks in favor of notifications
- โฑ #320 - Pausing indefinetely with nil pause timeout doesn't work
- #318 - Partition pausing doesn't work with custom topic mappers
- ๐ Rename ConfigAdapter to ApiAdapter to better reflect what it does
- #317 - Manual offset committing doesn't work with custom topic mappers
- ๐ #319 - Support for exponential backoff in pause
-
v1.2.2 Changes
- ๐ #312 - Broken for ActiveSupport 5.2.0
-
v1.2.1 Changes
- #304 - Unification of error instrumentation event details
- #306 - Using file logger from within a trap context upon shutdown is impossible
-
v1.2.0 Changes
- Spec improvements
- #260 - Specs missing randomization
- #251 - Shutdown upon non responding (unreachable) cluster is not possible
- ๐ #258 - Investigate lowering requirements on activesupport
- #246 - Alias consumer#mark_as_consumed on controller
- #259 - Allow forcing key/partition key on responders
- #267 - Styling inconsistency
- ๐ #242 - Support setting the max bytes to fetch per request
- ๐ #247 - Support SCRAM once released
- ๐ง #271 - Provide an after_init option to pass a configuration block
- #262 - Error in the monitor code for NewRelic
- ๐ #241 - Performance metrics
- #274 - Rename controllers to consumers
- ๐ #184 - Seek to
- #284 - Dynamic Params parent class
- #275 - ssl_ca_certs_from_system
- #296 - Instrument forceful exit with an error
- ๐ Replaced some of the activesupport parts with dry-inflector
- ๐ Lower ActiveSupport dependency
- โ Remove configurators in favor of the after_init block configurator
- ๐ Ruby 2.5.0 support
- ๐ Renamed Karafka::Connection::Processor to Karafka::Connection::Delegator to match incoming naming conventions
- ๐ Renamed Karafka::Connection::Consumer to Karafka::Connection::Client due to #274
- โ Removed HashWithIndifferentAccess in favor of a regular hash
- 0๏ธโฃ JSON parsing defaults now to string keys
- Lower memory usage due to less params data internal details
- ๐ Support multiple
after_init
blocks in favor of a single one - Renamed
received_at
toreceive_time
to follow ruby-kafka and WaterDrop conventions - ๐ Adjust internal setup to easier map Ruby-Kafka config changes
- System callbacks reorganization
- Added
before_fetch_loop
configuration block for early client usage (#seek
, etc) - Renamed
after_fetched
toafter_fetch
to normalize the naming convention - Instrumentation on a connection delegator level
- โ Added
params_batch#last
method to retrieve last element after unparsing - All params keys are now strings
-
v1.1.2 Changes
- ๐ #256 - Default kafka.seed_brokers configuration is created in invalid format
-
v1.1.1 Changes
- ๐ #253 - Allow providing a global per app parser in config settings
-
v1.1.0 Changes
- Gem bump
- Switch from Celluloid to native Thread management
- ๐ Improved shutdown process
- ๐ Introduced optional fetch callbacks and moved current the
after_received
there as well - ๐ฉ Karafka will raise Errors::InvalidPauseTimeout exception when trying to pause but timeout set to 0
- ๐ Allow float for timeouts and other time based second settings
- ๐ Renamed MessagesProcessor to Processor and MessagesConsumer to Consumer - we don't process and don't consumer anything else so it was pointless to keep this "namespace"
- ๐ #232 - Remove unused ActiveSupport require
- #214 - Expose consumer on a controller layer
- #193 - Process shutdown callbacks
- ๐ Fixed accessibility of
#params_batch
from the outside of the controller - connection_pool config options are no longer required
- celluloid config options are no longer required
- ๐
#perform
is now renamed to#consume
with warning level on using the old one (deprecated) - #235 - Rename perform to consume
- โฌ๏ธ Upgrade to ruby-kafka 0.5
- Due to redesign of Waterdrop concurrency setting is no longer needed
- #236 - Manual offset management
- ๐ WaterDrop 1.0.0 support with async
- Renamed
batch_consuming
option tobatch_fetching
as it is not a consumption (with processing) but a process of fetching messages from Kafka. The messages is considered consumed, when it is processed. - ๐จ Renamed
batch_processing
tobatch_consuming
to resemble Kafka concept of consuming messages. - Renamed
after_received
toafter_fetched
to normalize the naming conventions. - ๐ Responders support the per topic
async
option.
-
v1.0.1 Changes
October 27, 2017- #210 - LoadError: cannot load such file -- [...]/karafka.rb
- 0๏ธโฃ Ruby 2.4.2 as a default (+travis integration)
- โฌ๏ธ JRuby upgrade
- ๐ Expanded persistence layer (moved to a namespace for easier future development)
- #213 - Misleading error when non-existing dependency is required
- #212 - Make params react to #topic, #partition, #offset
- #215 - Consumer group route dynamic options are ignored
- ๐ #217 - check RUBY_ENGINE constant if RUBY_VERSION is missing (#217)
- ๐ง #218 - add configuration setting to control Celluloid's shutdown timeout
- ๐ Renamed Karafka::Routing::Mapper to Karafka::Routing::TopicMapper to match naming conventions
- ๐ #219 - Allow explicit consumer group names, without prefixes
- ๐ Fix to early removed pid upon shutdown of demonized process
- max_wait_time updated to match https://github.com/zendesk/ruby-kafka/issues/433
- ๐ #230 - Better uri validation for seed brokers (incompatibility as the kafka:// or kafka+ssl:// is required)
- ๐ Small internal docs fixes
- Dry::Validation::MissingMessageError: message for broker_schema? was not found
- โ #238 - warning: already initialized constant Karafka::Schemas::URI_SCHEMES