MongoMapper v0.15.0 Release Notes

Release Date: 2020-09-14 // over 1 year ago
  • * Upgrade to use modern mongo by upgrading to use the mongo 2.0 driver.
    
      This update means MongoMapper should work with any version of mongo after (2.6+).
    
      Many thanks to Frederick Cheung <[email protected]> for his contribution.
    
      Note that MyModel.collection now returns a mongo 2.0 driver collection object which does not mirror the shell methods.
    
      Patches welcome for a compatibility layer!
    
    * Support for ruby 2.4+, rails 5.0+
    * Dropping support for all older rubies, older rails.