10

8

6

4

2


7.1
0.0

4.3

8.9

4.2
0.0

2.7

8.1

9 GUI gems and projects

  • Shoes

    7.1 0.0 L5 Ruby
    Shoes 4 : the next version of Shoes
  • RubyGnome2

    4.3 8.9 L4 Ruby
    A set of bindings for the GNOME libraries to use from Ruby.
  • qtbindings

    4.2 0.0 L1 C++
    An easy to install gem version of the Ruby bindings to Qt
  • Glimmer

    2.7 8.1 Ruby
    DSL Framework consisting of a DSL Engine and a Data-Binding Library used in Glimmer DSL for SWT (JRuby Desktop Development GUI Framework), Glimmer DSL for Opal (Pure Ruby Web GUI), Glimmer DSL for Tk (MRI Ruby Desktop Development GUI Library), Glimmer DSL for LibUI (Prerequisite-Free Ruby Desktop Development GUI Library), Glimmer DSL for GTK (Ruby-GNOME Desktop Development GUI Library), Glimmer DSL for XML (& HTML), and Glimmer DSL for CSS
  • Glimmer DSL for LibUI

    1.8 9.6 Ruby
    Glimmer DSL for LibUI (Prerequisite-Free Ruby Desktop Development GUI Library - No need to pre-install any prerequisites. Just install the gem and have platform-independent GUI that just works)
  • Glimmer DSL for SWT

    1.2 9.6 Ruby
    Glimmer DSL for SWT (JRuby Desktop Development GUI Framework)
  • Glimmer DSL for Tk

    0.9 9.5 Ruby
    Glimmer DSL for Tk (MRI Ruby Desktop Development GUI Library)
  • Gladiator (Glimmer Editor)

    0.7 6.0 Ruby
    Gladiator (short for Glimmer Editor) is a Glimmer DSL for SWT sample project under on-going development that demonstrates how to build a text editor in Ruby using Glimmer DSL for SWT (JRuby Desktop Development GUI Library). It is not intended to be a full-fledged editor by any means, yet mostly a fun educational exercise in using Glimmer. Gladiator is also a personal tool for shaping an editor exactly the way I like, with all the keyboard shortcuts I prefer. I leave building truly professional text editors to software tooling experts who would hopefully use Glimmer one day. Otherwise, I have been happily using Gladiator to develop all my open-source projects since May of 2020.
  • Glimmer DSL for GTK

    0.2 10.0 Ruby
    Glimmer DSL for GTK - Ruby-GNOME Desktop Development GUI Library

Add another 'GUI' Gem